Age | Commit message (Expand) | Author |
2020-07-24 | usb: cdns3: drd: simplify *switch_gadet and *switch_host | Pawel Laszczak |
2020-07-24 | usb: cdns3: core: removed overwriting some error code | Pawel Laszczak |
2020-07-24 | usb: cdns3: core: removed 'goto not_otg' | Pawel Laszczak |
2020-07-24 | usb: cdns3: Added CDNS3_ID_PERIPHERAL and CDNS3_ID_HOST | Pawel Laszczak |
2020-07-24 | usb: cdns3: drd: changed return type from int to bool | Pawel Laszczak |
2020-07-24 | usb: cdns3: drd: return IRQ_NONE explicitly. | Pawel Laszczak |
2020-07-24 | usb: cnds3: drd: deleted != | Pawel Laszczak |
2020-07-24 | usb: cdns3: drd: removed not needed variables initialization | Pawel Laszczak |
2020-07-24 | usb: cdns3: core: removed cdns3_get_current_role_driver function | Pawel Laszczak |
2020-07-24 | usb: cdns3: gadget: always zeroed TRB buffer when enable endpoint | Peter Chen |
2020-07-24 | usb: cdns3: ep0: delete the unnecessary operation | Peter Chen |
2020-07-24 | usb: cdns3: gadget: improve the set_configuration handling | Peter Chen |
2020-07-21 | USB: Replace HTTP links with HTTPS ones | Alexander A. Klimov |
2020-07-20 | Merge 5.8-rc6 into usb-next | Greg Kroah-Hartman |
2020-07-10 | usb: Use fallthrough pseudo-keyword | Gustavo A. R. Silva |
2020-07-09 | usb: cdns3: trace: fix some endian issues | Peter Chen |
2020-07-09 | usb: cdns3: ep0: fix some endian issues | Peter Chen |
2020-07-03 | usb: cdns3: ep0: Move 'zlp' description to appropriate function header | Lee Jones |
2020-07-03 | usb: cdns3: gadget: Fix a bunch of kernel doc issues | Lee Jones |
2020-07-03 | usb: cdns3: ep0: Fix a bunch of kerneldoc issues | Lee Jones |
2020-07-03 | usb: cdns3: core: Fix incorrect formatting and misspelled function arg docs | Lee Jones |
2020-07-01 | usb: cdns3: gadget: use unsigned int for 32-bit number | Peter Chen |
2020-07-01 | usb: cdns3: gadget: unsigned int is dereferenced as a wider unsigned long | Peter Chen |
2020-07-01 | usb: cdns3: ep0: delete the duplicate code | Peter Chen |
2020-06-29 | Merge 5.8-rc3 into usb-next | Greg Kroah-Hartman |
2020-06-27 | usb: cdns3: gadget: Replace trace_printk by dev_dbg | Nicolas Boichat |
2020-06-24 | usb: cdns3: ep0: add spinlock for cdns3_check_new_setup | Peter Chen |
2020-06-24 | usb: cdns3: trace: using correct dir value | Peter Chen |
2020-06-24 | usb: cdns3: ep0: fix the test mode set incorrectly | Peter Chen |
2020-06-24 | USB: ch9: add "USB_" prefix in front of TEST defines | Greg Kroah-Hartman |
2020-05-25 | Merge tag 'usb-for-v5.8' of git://git.kernel.org/pub/scm/linux/kernel/git/bal... | Greg Kroah-Hartman |
2020-05-25 | usb: cdns3: ep0: delete the redundant status stage | Peter Chen |
2020-05-25 | usb: cdns3: Fix runtime PM imbalance on error | Dinghao Liu |
2020-05-25 | usb: cdns3: gadget: assign interrupt number to USB gadget structure | Peter Chen |
2020-05-25 | usb: cdns3: change dev_info to dev_dbg for debug message | Peter Chen |
2020-05-25 | usb: cdns3: change "cdsn3" to"cdns3" | Peter Chen |
2020-05-25 | usb: cdns3: delete role_override | Peter Chen |
2020-05-25 | usb: cdns3: core: get role switch node from firmware | Peter Chen |
2020-05-18 | Merge 5.7-rc6 into usb-next | Greg Kroah-Hartman |
2020-05-14 | usb: cdns3: gadget: make a bunch of functions static | Jason Yan |
2020-05-09 | usb: cdns3: gadget: prev_req->trb is NULL for ep0 | Peter Chen |
2020-05-05 | usb: cdns3: mark local functions static | kbuild test robot |
2020-04-16 | usb: cdns3: gadget: make a bunch of functions static | Jason Yan |
2020-04-16 | usb: cdns3: change dev_info to dev_dbg for debug message | Peter Chen |
2020-04-16 | usb: cdns3: change "cdsn3" to"cdns3" | Peter Chen |
2020-04-16 | usb: cdns3: delete role_override | Peter Chen |
2020-04-16 | usb: cdns3: core: get role switch node from firmware | Peter Chen |
2020-03-26 | usb: cdns3: make signed 1 bit bitfields unsigned | Colin Ian King |
2020-03-19 | usb: cdns3: fix spelling mistake "wrapperr" -> "wrapper" | Colin Ian King |
2020-03-10 | Merge 5.6-rc5 into usb-next | Greg Kroah-Hartman |